Loading...
Loading...
An issue has been identified and occurs after upgrading to Australia Patch 4 and later where an instance node will fail to restart if there is a formula‑calculated field on the User [sys_user] table. The trigger that leads to this issue is if the Formula field is not empty and contains Formula Functions defined in the sys_formula_function table (ie IF, SEARCH, CONCATENATE). When the issue occurs, the node does not restart and logs a stack overflow error. The failure occurs during the platform’s schema loading phase, preventing the instance from coming online and impacting all users. Affected versions: Australia Patch 4 and later versions Steps to Reproduce 1. Create a custom field on the sys_user table with similar customized configuration: Name - u_test_field Type - String Max length - 40 Click Advanced View In related lists tab, under Calculated Value Calculated - true Calculation Type - Formula Formula - if(name> "", "Not empty","Empty") Click Submit 2. Restart the node Expected: Node restarts without issue Actual: Node is not able to restart and throws a stack overflow error: 2026-08-19 14:41:56 (634) glide SYSTEM SEVERE Servlet [amb-configuration] in web application [] threw load() exception java.lang.ExceptionInInitializerError: Exception java.lang.StackOverflowError [in thread "glide"] at java.base/java.lang.ThreadLocal.get(ThreadLocal.java:172)...
This problem is currently under review and targeted to be fixed in a future release. Subscribe to this Known Error article to receive notifications when more information becomes available. A workaround is available and it is recommended that affected instances apply it before upgrading to an affected version to avoid this issue. Any calculated-formula field on the sys_user table will need to be converted into an equivalent calculated-string field and the formula contents cleared. Each formula field is likely a unique customization; the following workaround steps are provided as guidance. Customers should determine the equivalent calculated field and verify its correctness. *Changes should be applied and tested first on a sub-production instance before applying to a production instance.* 1. Identify all fields where formula is not empty on the sys_user table: Query sys_dictionary list and filter for Table IS 'sys_user' AND Calculated (virtual) IS NOT EMPTY AND Formula (formula) IS NOT NULL ...OR run the below provided script in Scripts - Background: var gr = new GlideRecord('sys_dictionary'); gr.addQuery('name', 'sys_user'); gr.addNotNullQuery('virtual'); gr.addNotNullQuery('formula'); gr.query(); while (gr.next()) { gs.print("Formula field needs conversion: " + gr.getValue('element')); } 2. For each formula field identified on sys_user (from step 1): 2a. Change Calculation Type (virtual_type) from 'Formula' to 'Script' -- the Calculation field should appear. 2b. In the Calculation field, add the equivalent script for the formula. For example: 2c. Delete the formula string from the Formula field. This requires switching Calculation Type (virtual_type) back to 'Formula'. After removing, make sure to switch back to 'Script'. 2d. Save/Submit FAQ: Q. What if the workaround is not applied to an impacted instance before upgrading to affected Australia Patch 4 or later? A. If an impacted instance does not have the workaround applied before upgrading to an affected version, the instance will incur the issue. It will be necessary to work with Customer Support to rollback the instance to a state prior to upgrade (pre-Australia Patch 4), apply the workaround and re-apply the upgrade (Australia Patch 4 or later).
PRB2076449
Click on a version to see all relevant bugs
ServiceNow Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.