Loading...
Loading...
The following error is received: Error: Operation failed (failed to check credentials and get serial.) The register vCenter screen displays an error when the necessary login information is provided and submitted to register. The following messages are seen in the connector logs ( /home/kos/connectors/logs/vi_connector.log ): Backend ERROR - java.rmi.RemoteException: VI SDK invoke exception:java.rmi.RemoteException: VI SDK invoke exception:org.dom4j.DocumentException: null Nested exception: null; nested exception is: java.rmi.RemoteException: VI SDK invoke exception:org.dom4j.DocumentException: null Nested exception: null at com.vmware.vim25.ws.WSClient.invoke(WSClient.java:122) ~[vijava-rp.jar:?] at com.vmware.vim25.ws.VimStub.retrieveServiceContent(VimStub.java:1434) ~[vijava-rp.jar:?] at com.vmware.vim25.mo.ServiceInstance.<init>(ServiceInstance.java:88) ~[vijava-rp.jar:?] at com.vmware.vim25.mo.ServiceInstance.<init>(ServiceInstance.java:72) ~[vijava-rp.jar:?] at com.emc.recoverpoint.connectors.vi.infra.VsphereConnection.createServiceInstance(VsphereConnection.java:101) ~[vi_connector_commons.jar:?] at com.emc.recoverpoint.connectors.vi.infra.VsphereConnection.<init>(VsphereConnection.java:67) ~[vi_connector_commons.jar:?] at com.emc.recoverpoint.connectors.vi.infra.VsphereConnection.<init>(VsphereConnection.java:62) ~[vi_connector_commons.jar:?] Following messages are seen on UI: "Error: OPeration Failed (failed to check the credentails and get serial. )". In some versions, the messages may differ ( /home/kos/connectors/logs/vi_connector.log ): java.rmi.RemoteException: VI SDK invoke exception:java.rmi.RemoteException: VI SDK invoke exception:org.dom4j.DocumentException: Error on line 1 of document : Content is not allowed in prolog. Nested exception: Content is not allowed in prolog.; nested exception is: java.rmi.RemoteException: VI SDK invoke exception:org.dom4j.DocumentException: Error on line 1 of document : Content is not allowed in prolog. Nested exception: Content is not allowed in prolog. at com.vmware.vim25.ws.WSClient.invoke(WSClient.java:122) ~[vijava-rp.jar:?] at com.vmware.vim25.ws.VimStub.retrieveServiceContent(VimStub.java:1434) ~[vijava-rp.jar:?] at com.vmware.vim25.mo.ServiceInstance.<init>(ServiceInstance.java:88) ~[vijava-rp.jar:?] at com.vmware.vim25.mo.ServiceInstance.<init>(ServiceInstance.java:72) ~[vijava-rp.jar:?] at com.emc.recoverpoint.connectors.vi.infra.VsphereConnection.createServiceInstance(VsphereConnection.java:101) ~[vi_connector_commons.jar:?] at com.emc.recoverpoint.connectors.vi.infra.VsphereConnection.<init>(VsphereConnection.java:67) ~[vi_connector_commons.jar:?] at com.emc.recoverpoint.connectors.vi.infra.VsphereConnection.<init>(VsphereConnection.java:62) ~[vi_connector_commons.jar:?] at com.emc.recoverpoint.connectors.vi.rpa.Cache.checkCredentialsAndGetSerial(Cache.java:132) [vi_rpa.jar:?] at com.emc.recoverpoint.connectors.vi.rpa.commands.CheckCredentialsAndGetSerialCommand.attemptToExecute(CheckCredentialsAndGetSerialCommand.java:36) [vi_rpa.jar:?] at com.emc.recoverpoint.connectors.commons.BaseCommand.call(BaseCommand.java:25) [connectors_commons.jar:?] at com.emc.recoverpoint.connectors.vi.rpa.BaseConnectorImpl.checkConnectionAndGetSerial(BaseConnectorImpl.java:55) [vi_rpa.jar:?] at com.emc.recoverpoint.connectors.vi.rpa.VIConnectorRegistrar$69.call(VIConnectorRegistrar.java:2869) [vi_rpa.jar:?] at com.emc.recoverpoint.mpi.transport.MPIRpcSessionListener.onUserCmd(MPIRpcSessionListener.java:165) [jmpi.jar:?] at com.emc.recoverpoint.mpi.transport.MPISession$2.run(MPISession.java:224) [jmpi.jar:?] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_211] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_211] at java.lang.Thread.run(Thread.java:748) [?:1.8.0_211] Caused by: java.rmi.RemoteException: VI SDK invoke exception:org.dom4j.DocumentException: Error on line 1 of document : Content is not allowed in prolog. Nested exception: Content is not allowed in prolog. at com.vmware.vim25.ws.XmlGenDom.fromXML(XmlGenDom.java:88) ~[vijava-rp.jar:?] at com.vmware.vim25.ws.WSClient.invoke(WSClient.java:118) ~[vijava-rp.jar:?] ... 16 more
RecoverPoint is creating a service instance object that is required to connect to vCenter and acquire vCenter's serial. RecoverPoint calls the Virtual Infrastructure Java ( vijava ) API request for the service instance by passing URL, user, and password. A soap request by vijava is created to communicate to the VMware API. Due to certain restrictions imposed by VMware with vSphere 7.0, any SOAP request with empty soapAction header value is treated as a noncompliance with HTTP 1.1 specifications and is rejected.
Workaround: Connect to any vCenter version earlier than vCenter 7.0. Resolution: This issue is resolved with RecoverPoint 5.1 SP4 Patch 3 (5.1.4.3).
Click on a version to see all relevant bugs