Loading...
Loading...
After upgrading Veeam Backup & Replication to version 13, attempts to upgrade the remote components on a highly available System Center Virtual Machine Manager (SCVMM) management server using the Veeam Backup & Replication Console fail with the following error: Failed to create persistent connection to ADMIN$ shared folder on host. The network path was not found. (ERROR_BAD_NETPATH).
This issue occurs because the method for communicating with SCVMM changed in Veeam Backup & Replication 13.0.1. In Veeam Backup & Replication 12.x, SCVMM communication was handled by the SCVMM console and its PowerShell snap-in, both of which were installed locally on the Veeam Backup Server. With all communication being handled locally through the installed snap-in, highly available SCVMM deployments were supported without additional configuration. Because the SCVMM console is available only on Windows, a new method for communicating with SCVMM was needed when the Linux-based Veeam Backup Server (Veeam Software Appliance) was introduced. To that end, starting in Veeam Backup & Replication 13.0.1, a Veeam management component is installed directly on the SCVMM management server. That component acts as a proxy for SCVMM communication. In a highly available SCVMM deployment, the management role is hosted by more than one server, and the remote component upgrade cannot be completed against such a configuration.
Windows-based Veeam Backup & Replication Deployments Only This procedure is intended only for Windows-based Veeam Backup & Replication Deployments. The Veeam Software Appliance does not support the SCVMM High Availability feature.
Veeam Backup & Replication User Guide > Adding Microsoft Hyper-V Servers > Before You Begin
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.