Loading...
Loading...
When upgrading Veeam ONE from version 12.3 to version 13, the following error occurs: Win32 exception occurred while executing SQL script. Error code: 0x80004004. Error details: The SELECT permission was denied on the object 'sysjobs', database 'msdb', schema 'dbo'.
This error occurs because the service account lacks permissions to the 'sysjobs' table in the 'msdb' database. Access to this table is mandatory starting with Veeam ONE v13. Veeam ONE needs access to the 'sysjobs' table to ensure there are no outdated SQL Server Agent Jobs for the Veeam ONE database Indexes Maintenance task created by older versions of Veeam ONE.
To resolve this issue, ensure that the Veeam ONE service account has all required permissions as documented in the product user guide: Connection to Microsoft SQL Server - Veeam ONE User Guide.
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.