Loading...
Loading...
When attempting to restore a VM with a QEMU version lower than 10 and disks in QCOW2 format to a Proxmox VE v9 node, the following error occurs: 16.09.2025 10:25:28 Error Linux-8.0 : Failed to reach the hypervisor. Error output: storage for 'local-LVM:vm-42-disk-1.qcow2' is configured for snapshots as a volume chain - this requires QEMU machine version >= 10.0. See https://pve.proxmox.com/wiki/QEMU_Machine_Version_Upgrade
This occurs when the restore destination storage has the setting "Allow Snapshots as Volume-Chain" enabled, causing the storage to require VMs on that storage to be QEMU version 10.
To workaround this issue, consider one of the following options: Restore to another storage that has Allow Snapshots as Volume-Chain disabled. Restore the disk as RAW. After the restore, if needed, convert the disk back to QCOW format manually inside Proxmox. See https://pve.proxmox.com/wiki/Storage_Migration. Consider your use case before choosing to restore to RAW format. While conversion to QCOW2 is possible using the Move Disk function, it may require updating the VM's QEMU version. This can cause compatibility issues. Therefore, disk format conversion should be done with caution.
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.