Loading...
Loading...
When attempting to perform mass recovery using Instant Recovery to Azure, the restore fails with the following error messages, which may be found within the UI and logs: Specific error messages: TooManyPendingCreatAccountOperations TooManyRequests Generic error messages: The request failed due to an internal error The request wasn't completed in time. Cannot validate argument on parameter 'parameter_name'. The argument is null", If the restore was started using PowerShell cmdlets
When this occurs, the restore settings and Veeam Backup & Replication configuration must be adjusted for mass recovery. The following factors may cause a mass restore to fail: Many Azure resources are created during the restore process, which may lead to Azure API throttling and subsequent restore failures. By default, restore jobs create temporary Azure storage accounts. The rate at which storage accounts can be created is limited, which may result in restore job failures. Mass recovery generates additional peak load on the backup server. Both restored VMs and temporary helper appliance VMs require sufficient CPU quotas and available IP addresses.
Mass Restore Preparation and Considerations Start preparations for mass restore by checking the latest version of these documents:
Veeam Backup & Replication: System Requirements Veeam Backup & Replication: Instant Recovery to Microsoft Azure - Considerations and Limitations Veeam Backup & Replication: Changing Template and Helper Appliance Size Veeam Data Platform 13 Recommended Maximums Veeam PowerShell Reference: Start-VBRAzureInstantRecovery Microsoft Documentation: Sizes for virtual machines in Azure
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.