Loading...
Loading...
Backup job of a personal site fails with: Failed to process site: {0}. Failed to resolve personal site owner. For more details, see KB4756.
This error indicates that Veeam Backup for Microsoft 365 was unable to correlate a Personal Site to a specific user because the owner of the site could not be resolved. This issue can occur in backup jobs that are configured to protect the Entire Organization or specific Groups, Sites, Personal Sites, Teams, or Organizations. In these cases, Veeam checks each Personal Site's properties to identify the owner (User), and if the metadata (such as the author property) is invalid or missing, the user cannot be correlated to the Personal Site, resulting in this error. However, when a backup job is configured to protect a specific User, Veeam is able to identify and protect the personal site(s) associated with that user, even if the site’s ownership properties are incomplete.
To work around this issue, perform the following to create a dedicated backup job for the affected personal site and exclude the site from the original job. Part 1: Create a Dedicated Backup Job for the Site Make sure that the backup job is configured to protect a User entity with "Site" selected in processing options. Create a new backup job. On the second step of job creation, select the option Back up the following objects: Click the Add... button and select Users... from the menu. Add the user associated with the personal site that failed to be backed up. Select that user in the Back up the following objects list. Click Edit... In the Edit Processing Options dialog box that opens, select the Site option. Proceed with the remaining job configuration.
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.