Loading...
Loading...
When the user attempts to use the Rollback function for a snapshot on a Proxmox Virtual Environment (PVE) Virtual Machine (VM) that is protected by Veeam Backup & Replication, the following error occurs: qemu-img: Could not apply snapshot '%%': Device has active dirty bitmaps
This error occurs because qemu, by default, does not allow the bitmap to be erased when applying the snapshot.
The solution depends on the disk type: RAW and VMDK Disks The bitmaps are not persistent. Turn the VM off to delete the dirty bitmap, then use the snapshot Rollback function. QCOW2 Disks The bitmaps are persistent; even powering the VM off will not delete them. Manual actions are required: Connect to the PVE node where the VM resides via SSH, and execute the following command:Note: In the command below, replace <vm-ID-#> with the VM's ID Number.
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.