Loading...
Loading...
After restoring a VM to Azure that ran Oracle Linux, that VM fails to boot.
Some Oracle Linux deployments may not include the Hyper-V-related UEK (Unbreakable Enterprise Kernel) modules, such as: hv_vmbus hv_storvsc hv_utils hv_netvsc When these modules are missing, issues can occur during VM recovery or conversion on Hyper-V-based Azure infrastructure. The following error may be seen in the logs during VM conversion: Info (3) dracut-install: Failed to find module 'hv_storvsc' Info (3) dracut: FAILED: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.EaHvEj/initramfs --kerneldir /lib/modules/5.15.0-306.177.4.el8uek.x86_64/ -m hv_vmbus hv_storvsc hv_utils hv_netvsc This failure prevents proper driver inclusion in the initramfs, leading to boot failure in the Azure environment.
Install kernel UEK Modules To resolve the issue: Install the kernel UEK modules package on the original VM corresponding to the current kernel version. Create a new restore point. Reattempt the restore using the new restore point. The following command will install the kernel-specific UEK modules, ensuring the missing Hyper-V modules can be included in the initramfs.
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.