Loading...
Loading...
While attempting to Install or Upgrade Veeam Backup & Replication, the installer displays the message: Windows Script Host must be enabled for the duration of setup process, Refer to KB4699 for more information https:// www.veeam.com/kb4699.
This message is displayed when the Installer detects that the Windows Script Host has been disabled. The disabling of the Windows Script Host is recommended as part of the Security & Compliance Analyzer and is disabled when using the script to automate the implementation of Security & Compliance Analyzer Recommendations from KB4525. However, as documented in the Security & Compliance Analyzer documentation: Before disabling Windows Script Host, make sure that this service is not used by the backup infrastructure components you plan to install on the backup server. If there are any (for example, PostgreSQL database), install these components first, then disable the service. To update these components, you need to enable the service temporarily.
There is no need to close the installer; it can remain open with the error displayed during the following step. Enable the Windows Script Host. (Does not require a reboot.)This can be done manually or by using the provided PowerShell command: Delete the registry value named 'Enabled' which may present within either of the following registry keys: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Script Host\Settings\ HKEY_CURRENT_USER\Software\Microsoft\Windows Script Host\Settings\ PowerShell script to delete the registry value from the two possible registry keys:Note: If the registry value is not present as a user-level setting within HKCU, the script will throw an error that can be disregarded.
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.