Loading...
Loading...
While upgrading Veeam Backup & Replication to version 12.3, the installer fails during "Step 1 of 7: Installing PostgreSQL server 15.10-1".
In the scenario described, the Veeam Backup & Replication 12.3 upgrade fails to install PostgreSQL 15.10-1 because the Windows Script Host has been disabled. The disabling of the Windows Script Host is recommended as part of the Security & Compliance Analyzer and is disabled when using the script to automate the implementation of Security & Compliance Analyzer Recommendations from KB4525. However, as documented in the Security & Compliance Analyzer documentation: Before disabling Windows Script Host, make sure that this service is not used by the backup infrastructure components you plan to install on the backup server. If there are any (for example, PostgreSQL database), install these components first, then disable the service. To update these components [PostgreSQL], you need to enable the [Windows Script Host] service temporarily.
If the upgrade fails as described, do not attempt to upgrade Veeam Backup & Replication a second time without first completing the relevant solution steps in this article. However, if you have already run the upgrade a second time, and the upgrade appears to have succeeded, please review the second solution section of this article.
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.