Loading...
Loading...
After adding Proxmox VE (PVE) hosts to Veeam Backup & Replication, the workers are deployed, but the testing phase fails with the error: If the server where Veeam Backup & Replication is installed is running Server 2012: System.ComponentModel.Win32Exception (0x80090308): The token supplied to the function is invalid If the server where Veeam Backup & Replication is installed is running Server 2012 R2: Failed to connect to the worker core service: Failed to connect to the backup appliance
These errors occur because the CBC-based ciphers that Server 2012 and Server 2012 R2 use for TLS1.2 communication are not supported by PVE.
Option 1: Upgrade the Windows OS Upgrade the machine that Veeam Backup & Replication is installed on to Windows Server 2016 or newer. Recomended, considering both Server 2012 and Server 2012 R2 reached End of Life in October of 2023. Solution 2: Apply Security Update 3174644 If an upgrade is not feasible, install Security Advisory# 3174644 to the Server 2012/2012 R2 machine where Veeam Backup & Replication is installed. https://learn.microsoft.com/en-us/security-updates/SecurityAdvisories/2016/3174644 https://catalog.update.microsoft.com/Search.aspx?q=KB3174644
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.