Loading...
Loading...
When attempting to add a Microsoft Entra ID Tenant to Veeam Backup & Replication a pop-up error is shown: Database connection settings for the Microsoft Entra ID backup repository cannot be found. Configure the repository according to this KB article to continue.
This error occurs when the Microsoft Entra ID backup repository connection settings have not been configured.
Overview To resolve this issue, you must ensure that a valid PostgreSQL instance is specified within the database connection settings for the Microsoft Entra ID backup repository.
The installer logic of whether to configure the Microsoft Entra ID backup repository is as follows: For a New Veeam Backup & Replication Deployment Is there an existing PostgreSQL 15 instance present on the machine? No — Deploy a new PostgreSQL 15 instance and configure Veeam Backup & Replication and the Microsoft Entra ID backup repository to use it. Yes — Switch the installer to advanced mode and prompt the user to specify PostgreSQL connection information. If the user provides connection details for the existing local PostgreSQL instance, configure Veeam Backup & Replication and the Microsoft Entra ID backup repository to use it. If the user does not provide credentials to connect to the existing local PostgreSQL instance and instead provides connection details for a local Microsoft SQL Server instance or a remote PostgreSQL or Microsoft SQL Server instance, configure VBR to use that instance but leave the Microsoft Entra ID backup repository settings blank.
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.