Loading...
Loading...
Export Action or Restore Action of OpenShift Imagestream fails with the following error: Failed to exec command in pod: command terminated with exit code 1.stdout: error writing layer: write/var/lib/image/<id>/blobs/sha256/<id>: no space left on device
During the export or restore of an image stream, a temporary persistent volume will be created using the default storage class. In some instances, the allocated size of that temporary intermediate volume created for exporting or restoring images is insufficient for the intended image size. This can result in a “no space left on device” error. In such a situation, the default value of ephemeralPVCOverhead of 0.1 is insufficient.
Increase the value of ephemeralPVCOverhead as needed. By default, it is 0.1, and it can be increased as needed. For example, to increase it to 0.2, the following commands would be used:
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.