Loading...
Loading...
Description: Jobs fail to run after reinstalling Veeam Kasten for Kubernetes on the same cluster Veeam Kasten for Kubernetes backups can be transferred to any S3-compliant object store to keep secondary copies and for long-term retention based on compliance needs. Both metadata and data are saved in a location defined by the cluster-ID. To prevent accidental loss, Veeam Kasten for Kubernetes will refuse to overwrite this data in case it is deleted and reinstalled and will display errors if new backups on a new Veeam Kasten for Kubernetes install are initiated. Error: "Failed to connect to backup repository: invalid repository password" Veeam Kasten for Kubernetes uses passkeys (automatically generated or user-defined) to protect metadata and data. Since this is unique to each Veeam Kasten for Kubernetes deployment, and because old data exists in the same backup location, a reinstalled Veeam Kasten for Kubernetes instance will run into conflicts.
To overcome this failure, existing data in the object storage location must be removed from the previous cluster. Part 1: Extract Cluster ID To do this, first, extract the cluster ID of the current cluster (to know which one shouldn't be removed). Cluster ID can be extracted in two ways: Cluster ID Extraction with CLI
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.