Loading...
Loading...
Description: XFS kernel module remembers the old UUID and refuses to mount Cloning an XFS volume and mounting the filesystem of the cloned volume on the same node as the source volume will throw a “duplicate UUID” error or similar errors. The cloning of the volume reflects everything from the source at the point of time of the snapshot, which also includes the UUID of the partitions within the volume. The UUID is the unique identifier pointing to the partition, and hence it is not unique anymore with the cloned volume on the host. This is generally not an issue when the cloned volume is attached to a different host than that of the source volume. Error: Filesystem has duplicate UUID - can't mount For EXT4 filesystems, even though /var/log/messages shows an error about the device appearing twice with different sysfs paths, it doesn’t throw the error when mounting the filesystem from the cloned volume.
The UUID of the partition should be changed before it is mounted. The commands vary based on the filesystem type (EXT4 vs XFS) but the idea is to change the UUID of the partition and mount. Run xfs_repair first on the partition, followed by xfs_admin to generate a new UUID.
An alternate solution is to mount the XFS volume using the nouuid mount option. While this will likely work around the issue, it is not always recommended.
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.