Loading...
Loading...
When attempting to write a restore point (VBK or VIB) to a Linux repository with a 4k logical block size, the task fails with the error: Invalid argument Asynchronous request operation has failed. Failed to open storage for read/write access
This error occurs when the storage device is formatted with a 4k logical block size and the Veeam Data Mover Service does not have sufficient permissions to determine the logical block size. On a Linux repository, the Veeam Data Mover Service must have read access to the following file for each device where a restore point would be written: /sys/dev/block/{id}/queue/logical_block_size If the Veeam Data Mover Service cannot access this file to determine the device's logical block size, the service will use the default file system block size of 512 bytes. However, if the block size is actually 4096 bytes, this usage of 512 bytes will cause the operation to fail.
To prevent this issue, ensure that the user account used to install the Veeam Data Mover service is able to read the logical block size of each device (/sys/dev/block/{id}/queue/logical_block_size). Check Permissions On the Linux repository, check the current permissions using the following command:
For other requirements and limitations affecting services installed on managed Linux servers, see Veeam Data Mover Service and Linux Server.
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.