Loading...
Loading...
After enabling Veeam Kasten for Kubernetes reports, reports are not generated. When running an on-demand report policy, the following error message is observed within the executor logs: "message":"Post "http://prometheus-server-exp:80/k10/prometheus/api/v1/query\": dial tcp: lookup prometheus-server-exp on 192.0.0.10:53: no such host" cause":{"message":"Failure in subordinate phase","function":"kasten.io/k10/kio/exec/phases/phase.(*queueAndWaitChildrenPhase).processGroup","linenumber":196,"file":"kasten.io/k10/kio/exec/phases/phase/queue_and_wait_children.go:196","fields":[{"name":"FailedSubPhases","value":[{"Phase":"","Err":{"cause":{"cause":{"cause":{"cause":{"cause":{"message":"Post "http://prometheus-server-exp:80/k10/prometheus/api/v1/query\": dial tcp: lookup prometheus-server-exp on 192.0.0.10:53: no such host"},"fields":[{"name":"query","value":"sum(round(increase(action_backup_skipped_overall{cluster=""}[24h])))"}]
This issue occurs when the Prometheus server hostname cannot be resolved via DNS, which prevents Veeam Kasten for Kubernetes pods (i.e., Executor pods) from capturing the Prometheus metrics. Since the Prometheus instance metrics cannot be collected, the Veeam Kasten for Kubernetes reports, which depend on those metrics, cannot be generated. This may also occur when the DNS server is not running. lookup prometheus-server-exp on 192.0.0.10:53: no such host
Cluster DNS Validation Validate the cluster DNS by following this DNS troubleshooting guide. The following commands can be used to help to check DNS functionality within the cluster: DNS debugging example pod YAML from kubernetes documentation:
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.