Loading...
Loading...
Before requesting and applying this hotfix, ensure that Veeam Backup & Replication 12 P20230718 is installed. You can check the installed build number in the Veeam Backup & Replication Console's Main Menu (≡) under Help > About.
This hotfix improves how Veeam Backup & Replication 12 manages self-signed certificates used by on-premises object storage when the self-signed certificates have not been manually imported, resolving the following issues: Saving IAM/STS endpoints for a repository fails with the following errors: Failed to find valid gateway server for non-scheduled repository <repo_name>: Unable to verify certificate: certificate host name validation failed Unable to change encryption settings because the object storage repository is unavailable. Ensure the repository is reachable from the backup server and try again. Agent jobs targeting repositories with IAM/STS, including Cloud Connect, fail when tenants have not manually imported the self-signed certificates, leading to the error: A WebException with status TrustFailure was thrown Running VM jobs (IAM/STS and Insecure Direct) in Cloud Connect cases fails with: Amazon S3 Compatible connection has returned an untrusted certificate. Both the Service Provider and their Tenants must install this hotfix to resolve these issues.
To acquire this hotfix, please create a case with Veeam Support requesting the hotfix associated with Issue ID#577015. To prevent conflicts with existing hotfixes that may be installed, a support case must be created to acquire this hotfix so that Veeam Support can assess whether the patched files of this hotfix conflict with any hotfix that may already be installed.
Click on a version to see all relevant bugs
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.