Loading...
Loading...
When utilizing Always On Availability Groups on a Windows Server Failover Cluster using Microsoft SQL Server 2017 and after installing Cumulative Update package 15 (CU15) for SQL Server 2017, Veeam Transaction Log Backup Jobs may fail with the following error message in the the statistics window for the transaction log backup job: Configuration data for the availability group with Windows Server Failover Clustering (WSFC) resource ID '' is not found in the WSFC data store. The availability group may have been dropped, or a previous CREATE AVAILABILITY GROUP or DROP AVAILABILITY GROUP operation has failed. Please use DROP AVAILABILITY GROUP command to clean up previously failed operations before retrying the current operation.
The error is a result of a known issue in CU15 for SQL Server 2017. Please see the section on Availability Group Preferred Replica Backups. The issue has been resolved in the hotfix linked below.
Please apply the hotfix provided by Microsoft: https://support.microsoft.com/en-us/help/4506633/on-demand-hotfix-update-package-for-sql-server-2017-cu15
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.