Loading...
Loading...
The upgrade to Veeam Backup & Replication U4 fails with "Database version downgrade detected ... Reboot and restart the setup". You may find following error in the C:\ProgramData\Veeam\Setup\Temp\BackupSrvLog.log:***Veeam*** SRV: [31.01.2019 11:39:43]:<00000001> [VEEAM] Database version has been incremented to <5186> ***Veeam*** SRV: [31.01.2019 11:39:43]:<00000001> [VEEAM] Executing version command (ContentType=[Schema], Version=<5186>) ***Veeam*** SRV: [31.01.2019 11:39:43]:<00000001> [VEEAM] Adding trusted hosts (InitialCatalog=[VeeamBackup], DatabaseVersion=<5186>) ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] declare @id uniqueidentifier; ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] set @id = '52107791-e0ff-4538-a26e-4717962aef77'; ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] declare @usn bigint; ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] exec IncrementUsn @usn output; ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] BEGIN ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] INSERT INTO [dbo].[Backup.Model.HostSshFingerprint] ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] ( ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] [id], [network_name], [accepted_fingerprint], [current_fingerprint], [public_key], [agent_id], [network_name_hash], [last_update_time], [usn] ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] ) ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] VALUES ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] ( ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] @id, '<IP Address>', '', '', '', '00000000-0000-0000-0000-000000000000', '', '<Day>/<Month>/Year <time>', @usn ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] ) ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] END; ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM] [SQL|ERROR] GO ***Veeam*** SRV: [31.01.2019 11:39:44]:<00000001> [VEEAM|ERROR] Conversion failed when converting date and/or time from character string. (System.Data.SqlClient.SqlException)
This is a known issue in Veeam Backup & Replication 9.5 U4. There are 2 mandatory conditions for this issue to raise: System time format uses a.m. and p.m. (in small symbols with dots) Application-aware processing, or guest OS file indexing is enabled for a Linux machine. Affected regional formats and countries are: English (New Zealand) Greek (Greece) Maori (New Zealand) Spanish (Argentina) Spanish (Bolivia) Spanish (Costa Rica) Spanish (Honduras) Spanish (Nicaragua) Spanish (Peru) Spanish (Puerto Rico) Spanish (Paraguay) Spanish (El Salvador) Spanish (Bolivarian Republic of Venezuela) Galician (Galician) Guarani (Paraguay) K'iche (Guatemala) Quechua (Bolivia) Quechua (Peru) Romanian (Romania)
Note: This issue is now resolved in Update 4a. Please download the new Update ISO and install Update 4a instead of Update 4.
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.