Loading...
Loading...
After successfully restoring a UEFI-based machine running Server 2008 R2 SP1 to a Hyper-V host, the VM fails to boot.
The machine fails to boot due to a machine configuration that conflicts with Hyper-V. For Hyper-V guest Virtual Machines, Server 2008 R2 is only support for use with Generation 1. UEFI-based boot is only supported by the virtual machines using Generation 2.
As Hyper-V only supports Server 2008 R2 running in a Generation 1 VM, and Generation 1 in turn only supports MBR, the only solution to make the restored UEFI-based VM operational is to convert the bootloader from the incompatible UEFI (GPT) to MBR. This process is documented in the Solution section of KB2407.
Windows guest operating system support
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.