Loading...
Loading...
When Microsoft User Profile Disks (for example, in a Windows RDS farm) are used, Veeam Application Aware Image Processing through vSphere API may fail with the following error: Could not invoke guest operation.
When processing Guest OS data through vSphere API, Veeam needs to deploy a runtime component in a temporary location. C:\Windows\Temp\ folder had been used for these purposes previously. However, starting from 10.2.0 VMware tools’ version, the Temp folder location has been changed to C:\Users\username\Temp\. When User Profile Disks feature is used, Windows has no User’s profile temp folder unless a User is logged in (once a User is logged out, Temp folder is deleted). Hence, Veeam has no temp folder to place its components in.
VMware is planning to address this issue in one of the next VMware tools releases. As a workaround, you may want to downgrade VMware tools version to an earlier version or set up a direct network connection to the Guest OS from a Guest Interaction Proxy
https://helpcenter.veeam.com/docs/backup/vsphere/runtime_process.html?ver=95
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.