Loading...
Loading...
A Backup Copy or Replication job that uses WAN accelerator fails with any of the following errors: Error: Source WAN accelerator error: Failed to decompress LZ4 block: Bad crc Error: Source WAN accelerator error: Failed to decompress LZ4 block: Incorrect decompression result or length Error: Source WAN accelerator error: Client error: Zlib decompression error: [-3].
These errors may occur because the internal CRC check failed for either a source restore point or data within the WAN Accelerator Cache.
Issue Isolation To begin the investigation, isolate whether the issue is related to the WAN Accelerator Cache or the restore points. Edit the job that is failing. Switch to the Data Transfer section of the job configuration. Change the job to use Direct instead of Through built-in WAN accelerators. Run the job and observe the outcome.
The Windows event log on the repository server may contain Event ID 7: "The device… has a bad block." If so, run CHKDSK /F or CHKDSK /R. A small number of bad blocks are normal on most storage devices. If additional bad block events occur after running CHKDSK, check the SMART status and consider replacing the disk. If using a Network Attached Storage device, contact your storage vendor to determine what diagnostics are available. For more information, review: Veeam KB1795.
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.