Loading...
Loading...
A Replication job targeting a VVOL fails with the error: Error: VDDK error: 7 (A file access error occurred on the host or guest operating system). Value: 0x0000000000000007
This error occurs when attempting to replicate a VM to a VVOL datastore.
Due to a change starting in ESXi 6.0 Update 1, replication and quick migration to VVol datastores is not possible with either Veeam or vSphere replication.[1][2][3]
[1] https://www.veeam.com/veeam_backup_11_a_release_notes_rn.pdf p23[2] https://www.veeam.com/veeam_backup_12_release_notes_rn.pdf p24[3] https://www.veeam.com/veeam_backup_12_1_release_notes_rn.pdf p25 VMware VDDK Release Notes: Avoid creating snapshots for restore on VVol datastores. Due to Virtual Volume (VVol) implementation in the vSphere 6.0 release, VMware recommends against creating a snapshot (then reverting and deleting it) when restoring files on a VVol datastore. This is because writing to a non-leaf disk (such as a snapshot backing file) is considered a layering violation and throws an error on many VVol storage devices. Writing to the leaf disk of the snapshot is not a layering violation. The restore snapshot remains mandatory for SAN transport, which is not supported on VVol datastores anyway.
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.