Loading...
Loading...
A task fails with the error: Error: Failed to call RPC function 'StartAgent': Timed out requesting agent port for client sessions.
These errors may occur because of either: A firewall prevents the remote machine from initiating communication on one or more of the assigned transmission channel ports, causing the process to increment the port it attempted to use until it exhausted the list of ports it was given. or A Managed Server (Windows or Linux) has had its default configuration altered so that the range of ports it uses is insufficient, causing the process that is trying to start not to find an available port to use.Here is an extreme example where the Managed Server has been configured only to allow two ports to be used:
Check Firewalls Review the firewalls in the environment to ensure accommodations have been made for the ports used by Veeam Backup & Replication. Check Managed Server Configuration The default range of transmission channel ports is available in the Used Ports section of the user guide. Within the Veeam console, click Backup Infrastructure From the tree on the left, expand ‘Managed servers’ and select ‘Microsoft Windows’ On the right side, select the server related to the issue In the menu at the top of the screen, click Edit Server On the ‘Credentials’ tab, click the button labeled [Ports…] Within the network settings dialog, verify that the default or an appropriate number of ports have been assigned. Click OK to confirm the settings. Click Finish to commit the changes to that server.
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.