Loading...
Loading...
When the Veeam vPower NFS Service on the Mount Server used by the SureBackup job is set to use any account other than Local SystemThe default configuration is for the Veeam vPower NFS Service to "Log On As" the 'Local System' account., and that account is not a member of the Local Administrator user group, the SureBackup job will fail with errors similar to: Error: Failed to call RPC function 'AddConnection': Access is denied. Failed to create registry key [SOFTWARE\VeeaM\Veeam NFS\Connections\04dda549-aeac-422e-9534-d06592fef6f6]. RPC: Failed AddConnection.
The access is denied error occurs because the account that the Veeam vPower NFS Service service is set to use for 'Log On As' is not set to Local System and assigned account is not a member of the Local Administrators user group.
Review the Services (services.msc) running on the Veeam Backup Server and associated managed servers (proxies, repositories, etc.), and set the services to 'Log On As' Local System. This is the default configuration for all Veeam-named services. The only exception to using the Local System account for running the Veeam named services is when the VeeamBackup configuration database is hosted by a Microsoft SQL Server instance running on a remote server. In such a configuration, only the following services are modified to use a domain account to allow access to the configuration database on the remote SQL server: Veeam Backup Server RESTful API Service Veeam Backup Service Veeam Broker Service Veeam CDP Coordinator Service Veeam Cloud Connect Service Veeam Guest Catalog Service
Related Articles KB1055: Troubleshooting vPower NFS Datastore Mounting Issues KB1094: Veeam vPower NFS Service fails to start KB1110: Unable to access the virtual machine configuration: Invalid datastore path KB1284: How to Test Manually Mounting the Veeam vPower NFS Datastore KB1289: fault.RestrictedVersion.summary KB1478: SureBackup fails: Failed to call RPC function - Access is Denied KB1690: Unable to Mount VeeamBackup_ Datastore - Specified Key, Name, or Identifier Already Exists KB4166: Upgrading/Uninstalling Veeam Backup & Replication fails with "Error 1327. Invalid Drive: [a-z]:\" or "Warning 1327. Invalid Drive [a-z]:\" KB4167: Linux Guest File Restore Cannot Connect Backup Datastore to ESXi Host KB4363: Datastore Named 'VeeamBackup_' Listed as Inaccessible KB4504: SureBackup Job Failure: "The resource 'VeeamBackup_' is in use."
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.