Loading...
Loading...
One or more virtual machines in a VMware Backup job fails with the following error: vSphere Environment Virtual Machine <VMname> is unavailable and will be skipped from processing.
These errors occur when the hypervisor fails to locate the Virtual Machine (VM) based on the reference ID that Veeam Backup & Replication (VBR) provided. When a VM is processed by a VBR job, that VM is tracked by the backend hypervisor reference ID to ensure that even if the machine is renamed or another VM is built with the same name, VBR will always protect the correct VM. In a vSphere environment, this unique reference ID is called a Managed Object Reference ID, or MORef-ID. In a Hyper-V environment, the unique reference ID is called a Virtual Machine ID, or VMID.
Scenario 1: The VM No Longer Exists If the VM was removed from the infrastructure and no longer exists, remove it from the Veeam job.
The resolution can be confirmed without running the job. Edit the job, navigate to the "Virtual Machines" tab, and click the [Recalculate] button. Note that the VM(s) whose reference ID(s) changed now report as having the correct size. The most common events that cause a VM's reference ID to change are: For vSphere Environments: A VM is removed from inventory and then added back to inventory. In rare cases, a host crash, which prompts the host to be removed and added back to the vCenter, may cause the VMs on that host to get new MoRef-IDs. Reinstallation or creating a new vCenter server where the old database is not reused will cause all objects managed by the vCenter to receive new unique identifiers.Customers are encouraged to utilize the vCenter's native file-based backup to protect and restore the configuration, ensuring unique reference IDs are preserved. For Hyper-V Environments: A VM is exported and reimported.
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.