Operational Defect Database

BugZero found this defect 439 days ago.

Veeam | kb4421

Veeam Agent Standalone Backup Fails with "Version string portion was too short or too long"

Last update date:

5/8/2023

Affected products:

Veeam Backup & Replication

Veeam Agent for Microsoft Windows

Veeam Agent for Linux

Veeam Agent for IBM AIX

Veeam Agent for Oracle Solaris

Affected releases:

4.1

Fixed releases:

No fixed releases provided.

Description:

Challenge

After upgrading Veeam Backup & Replication to version 12, the following tasks for Standalone Veeam Agent (i.e., Veeam Agent for Microsoft Windows, Veeam Agent for Linux, Veeam Agent for IBM AIX, and Veeam Agent for Oracle Solaris) deployments that existed before the upgrade may fail. Running Standalone Veeam Agent backup job Re-configuration of pre-existing Veeam Agent jobs Attempting to remove Veeam Agent jobs from Veeam Backup & Replication console Those tasks will fail with the error: Version string portion was too short or too long

Cause

This issue is caused by a change in how Veeam Backup & Replication 12 tracks OS version information from Standalone Veeam Agent deployments. This issue only affects standalone Veeam Agent deployments that were communicating with the Veeam Backup Server before the upgrade to version 12.

Solution

Option 1: Support-Assisted Resolution The resolution to this involves modifying the Veeam Backup & Replication Configuration Database. Veeam Support understands that some customers may not be comfortable performing this task, and we welcome you to contact Veeam Support for assistance. Our Support Engineers will assist with making the database changes necessary to resolve this issue.

Additional Resources / Links

Share:

BugZero® Risk Score

What's this?

Coming soon

Status

Solved

Learn More

Search:

...