Operational Defect Database

BugZero found this defect 469 days ago.

Veeam | kb4413

Veeam Backup & Replication Configuration Check displays error regarding unsupported Veeam Backup for Public Cloud product version

Last update date:

3/22/2023

Affected products:

Veeam Backup & Replication

Veeam Backup for AWS

Veeam Backup for Microsoft Azure

Affected releases:

5a

Fixed releases:

No fixed releases provided.

Description:

Challenge

During the upgrade to Veeam Backup & Replication 12, if theConfiguration Check detects that the Veeam Backup for AWS Plug-In or Veeam Backup for Microsoft Azure Plug-in is installed, the upgrade will be halted with the error: Unsupported Veeam Backup for AWS version Unsupported Veeam Backup for Microsoft Azure version   Below is an example of the error shown when Veeam Backup for AWS was in use. Veeam Backup & Replication V12 requires a later version of Veeam Backup for AWS than the one you are currently using. If you want to upgrade to V12 now, please remove Veeam Backup for AWS from the product configuration first.

Cause

This issue occurs when the Veeam Backup & Replication 12 ISO in use does not contain the latest Veeam Backup for AWS/Veeam Backup for Microsoft Azure Plug-Ins, and therefore cannot proceed with the installation because it cannot upgrade those Plug-Ins to the version that is compatible with Veeam Backup & Replication 12. More Information...

Solution

After Veeam Backup for AWS 6 and Veeam Backup for Microsoft Azure 5 were released, the Veeam Backup & Replication 12 P20230223 ISO was rebuilt to include the updated Plug-In installers. As such any Veeam Backup & Replication ISO with a filename datestamped 20230320VeeamBackup&Replication_12.0.0.1420_20230320.iso or later will not experience the error presented in this article. If you are experiencing this error while performing an upgrade to Veeam Backup & Replication 12, download and use the latest Veeam Backup & Replication 12 ISO available here:

More Information

When upgrading Veeam Backup & Replication it is critical that the Upgrade Checklist be reviewed.   ISOs with the following filenames were missing one or more Plug-Ins and would cause the issue presented in this article: VeeamBackup&Replication_12.0.0.1402_20230127.iso — Veeam Backup & Replication 12 RTM VeeamBackup&Replication_12.0.0.1420_20230209.iso — Veeam Backup & Replication 12 GA  VeeamBackup&Replication_12.0.0.1420_20230223.iso — Veeam Backup & Replication 12 P20230223 VeeamBackup&Replication_12.0.0.1420_20230303.iso  — Veeam Backup & Replication 12 P20230223  This ISO contained the Veeam Backup for AWS 6 Plug-In, but not the Veeam Backup for Microsoft Azure 5 Plug-In (as it hadn't been released at that time). The datestamp in the ISO's filename indicates when that ISO was created. The datestamp in the filename is not an indicator of the build number that the ISO will install. The Patch build number is characterized by the prefix 'P' in the build number's Pyyyymmdd schema. For example, VeeamBackup&Replication_12.0.0.1420_20230320.iso will deploy Veeam Backup & Replication 12 (build 12.0.0.1420 P20230223).

Additional Resources / Links

Share:

BugZero® Risk Score

What's this?

Coming soon

Status

Solved

Learn More

Search:

...