Operational Defect Database

BugZero found this defect 1950 days ago.

Veeam | kb2870

Veeam Backup Enterprise Manager RESTful APIs Upgrade Instructions

Last update date:

8/13/2020

Affected products:

Veeam Backup & Replication

Veeam Cloud Connect

Affected releases:

ALL

Fixed releases:

No fixed releases provided.

Description:

Challenge

Veeam Backup & Replication 9.5 Update 4 RTM is not compatible with the previous versions of API. Some integration may not work as expected.

Cause

Update 4 has introduced new Product functionality that requires extended API and incremented the required request version to v1_4.

Solution

The compatibility issue will be remediated in Update 4 GA.Hotfix is available for Veeam 9.5 Update 4 RTM, please contact Veeam Support for assistance.Alternatively, you can switch to version v1_4 with the considerations below.The following Cloud Connect functionality requires changing request's version from v1_3 to v1_4: Create, Edit tenants The following may require changing request's content: Tenant edit. GET request now returns a new tenant type block. Adding this block to PUT requests should allow functionality to work as intended: <TenantType>        <StandaloneTenant>           <TenantCredentials>              <Username>TENANT_NAME</Username>           </TenantCredentials>        </StandaloneTenant> </TenantType>   The element is described in the new XSD as follows:  <xs:element name="TenantType" type="CloudTenantType" minOccurs="0" maxOccurs="1"/> Task status. Complex tasks such as create/edit/delete tenant have got a new status OperationFinished which should be properly enumerated.

Additional Resources / Links

Share:

BugZero® Risk Score

What's this?

Coming soon

Status

Solved

Learn More

Search:

...