Loading...
Loading...
After installing the Windows June 14,2022 update (KB5014702/KB5014746) on a Windows file server hosting SMB 3.0 shares, the follow Veeam Backup & Replication operations may be impacted: If those SMB 3.0 shares are added to Veeam Backup & Replication with the "Backup from Microsoft VSS snapshot" option enabled, the NAS Backup job(s) protecting those SMB 3.0 shares may fail with the following error: Failed to create a VSS snapshot Error: Failed to add volume [\\SMB3FS\SHARE1\] to the VSS snapshot set The given shadow copy provider does not support shadow copying the specified volume. --tr:Failed to add volumes to the snapshot set. --tr:Failed to perform pre-backup tasks. If those SMB 3.0 shares are used to store VMs for a Hyper-V host running Server 2012R2, the Backup job(s) for the VMs stored on those SMB 3.0 shares may fail with the following error: Failed to create snapshot (Fileshare Provider) (mode: Crash consistent) Details: Failed to add volume [\\SMB3FS\VOLUME1\] to the VSS snapshot set The given shadow copy provider does not support shadow copying the specified volume. --tr:Failed to add volumes to the snapshot set. --tr:Failed to perform pre-backup tasks. When either type of job fails the following error will be found in the Windows Event Logs of the File Server hosting the SMB3.0 shares: Microsoft File Share Shadow Copy Agent Error: The client connecting to the FssAgent RPC server did not have Local Administrator or Backup Operator privilege on this machine.
NAS Backup Job Failure Review the following article from Microsoft: KB5015527: Shadow copy operations using VSS on remote SMB shares denied access after installing Windows update dated June 14, 2022 Specifically: Ensure that the June 14, 2022 update is installed on the following servers: File Server hosting the SMB 3.0 shares. The Veeam Backup Server. All Backup Proxies used by the NAS Backup job. Check the share permissions within Veeam Backup & Replication to ensure that Veeam has been configured to use a domain account that is a member of the Local Administrator or Backup Operator group on the File Server hosting the SMB 3.0 Shares.
Veeam Integration
Learn more about where this data comes from
BugZero Plan
Streamline upgrades with automated vendor bug scrubs
BugZero Prevent
Wish you caught this bug sooner? Get proactive today.